Outlook plug-in is available only for Windows computers with Windows 7/8/10 and Outlook 2010/2013/2016

Did this answer your question?